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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in this
guide.

« Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.
» Bold type is used for the following:

o Keyboard entries that should be typed in their entirety exactly as shown. For example,
“copy file1” means the word copy must be typed, then a space must be typed, and
then file1 must be typed.

o On-screen prompts and messages, names of options and text boxes, and menu com-
mands. Menu commands are often separated by carats. For example, “click
HFSS>Excitations>Assign>Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to press
the key labeled Enter.

« ltalictype is used for the following:
o Emphasis.
o The titles of publications.

o Keyboard entries when a name or a variable must be typed in place of the words in ital-
ics. For example, “copy file name” the word copy must be typed, then a space must
be typed, and then name of the file must be typed.

The plus sign (+) is used between keyboard keys to indicate that you should press the keys

at the same time. For example, “Press Shift+F1” means to press the Shift key and the F1
key at the same time.

Ribbons, menu bars, and short-cut menus are three methods that can be used to see what
commands are available in the application.

« Ribbons are the rectangular area on top of the application window and contain multiple tabs.
Each tab has relevant commands that are organized, grouped, and labeled. An example of a
typical user interaction is as follows:

"On the Draw ribbon tab, click the Box primitive" means you can click the Box icon on the
Draw tab and execute the Box command to draw a box.

» The menu bar (located above the ribbon) is a group of the main commands of an application
arranged by category such File, Edit, View, Project, etc. An example of a typical user inter-
action is as follows:

"On the File menu, click the Open Examples command" means you can click the File menu
and then click Open Examples to launch the dialog box.

« Another alternative is to use the short-cut menu that appears when you click the right-mouse
button. An example of a typical user interaction is as follows:
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“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands from
the short-cut menu (and the corresponding sub-menus).

Getting Help: ANSYS Technical Support

For information about ANSY'S Technical Support, go to the ANSYS corporate Support website,
https://www.ansys.com/Support. You can also contact your ANSYS account manager in order to
obtain this information.

AllANSYS software files are ASCII text and can be sent conveniently by e-mail. When reporting dif-
ficulties, it is extremely helpful to include very specific information about what steps were taken or
what stages the simulation reached, including software files as applicable. This allows more rapid
and effective debugging.

Help Menu
To access help from the menu bar, click Help and select from the menu:

« HFSS Contents - click here to open the contents of the help.
« HFSS Search - click here to open the search function of the online help.

Context-Sensitive Help
To access help from the user interface, do one of the following:

« Toopen ahelp topic about a specific menu command, press Shift+F1, and then click the
command or toolbar icon.

« Toopen a help topic about a specific dialog box, open the dialog box, and then press F1.
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Getting Started with HFSS: Waveguide T-Junction

1 - Introduction

This document is intended as supplementary material to HFSS for beginners and advanced users.
Itincludes instructions to create, solve, and analyze a T-junction.
This chapter contains the following topics:
« Overview of the Interface
« Distinctive Features of HFSS
o Sample Project: The Tee Junction

What You Will Learn:

You will learn to perform the following HFSS tasks in the ANSYS Electronics Desktop application:

« Setupthe Tee project

» Create the Tee model

« Modify a model’s design parameters

« Assign variables to a model’s design parameters

« Specify solution settings for a design

» Validate a design setup

o Runan HFSS simulation.

« Create a 2D x-y plot of S-parameter vs. Frequency
» Create afield overlay plot of results

« Create a phase animation of results

Overview of the Interface

This topic provides an overview of the ANSYS Electronics Desktop user interface in a typical con-
figuration. You can enable or disable the display of individual windows to suit your usage and pref-
erences. The following figure shows an HFSS design of a Tee Waveguide model within the
interface:
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Figure 1-1: The ANSYS Electronics Desktop User Interface — HFSS Design Example

The following table describes the different elements present within the user interface. You can con-
trol the visibility of individual windows from the menu bar by toggling the selection state of the cor-
responding options in the View menu.
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Project Manager Win
dow

Displays details of the design projects. Each project has its
own main branch of the project tree, which ultimately
includes various information and options (like the type of
design, boundaries and excitations, analysis setups, and
analysis results).

Modeler Window

Includes the drawing area of the active model and the His-
tory Tree (item 3). In this example, the E Field results of the
simulation are overlaid on the model in the drawing area.

History Tree

Displays all operations and commands carried out on the actj
ive model (such as information about the model’s objects, all
actions associated with each object, and coordinate system
information).

Ribbon

Contains various commands and options to create, manage,
set up, analyze, and evaluate your designs and to customize
program options. These commands and options are organ-
ized into related sets, with each logical group on a separate
tab. The ordering of the tabs is designed to follow a left-to-
right workflow. Certain popular commands (such as Save
and various View options) appear on multiple tabs.

Not all of the available commands can be accessed via the
ribbon. Others are accessed from the Menu Bar (item 5) and
shortcut menus that appear when you right-click.

Menu Bar

Provides various menus that enable you to perform all of the
modeling, viewing, and HFSS tasks (such as managing pro-
ject files, customizing the desktop components, drawing
objects, and setting and modifying all project parameters).

Properties Window

Displays the attributes of a selected object in the active
model (such as the object’s name, material assignment, ori-
entation, color, and transparency). This window also dis-
plays information about a selected command that has been
carried out. For example, if a circle was drawn, the inform-
ation about the command includes its name (CreateCircle),
the type and name of the coordinate system the circle was
drawn in, the coordinates of the circle’s center position, its
axis, and its radius.

To differentiate this window from the similar Properties dia-
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log box, it is typically referred to as the "docked Properties
window" within the Getting Started Guides.

7 Status Bar Shows current actions and provides instructions.
Also, depending on the command being carried out, the
status bar can display the X, Y, and Z (or dX, dY, and dZ)
coordinate boxes. Use the Absolute/Relative drop-down
menu to choose whether to enter a point’s absolute or rel-
ative coordinates. Additionally, there's a drop-down menu to
specify points in Cartesian, Cylindrical, or Spherical coordin-
ates and the active model’s unit setting.
8 Message Manager Displays errors, warnings, and informational messages for
Window an active project.
9 Progress Window Displays solution progress information.
10 |[Component Librar- | Thiswindow is one of several that you can optionally display
ies Window or hide via the View menu. It displays 3D components that

are stored in the SysLib and PersonalLib directories. From
here you can easily add 3D components into your project.

Other windows you can display here are the ACT Exten-
sions window (with various wizards to automate creation of
certain models) and windows containing Components, Lay-
ers, and Nets information.

Distinctive Features of HFSS

The High-Frequency Structure Simulator (HFSS) offers some special features to help you create
and work with your design and bring it into a desirable and effective condition. Some of the key fea-
tures are as follows:

« Numerous ways to perform similar tasks:

For example, you can select and assign design parameter values (variables), or you can

work with fixed parameters (constants). Additionally, you can access commands via the

menu bar, the ribbon, or via shortcut menus that appear when you right-click. In the latter
case, the contents of the menu depend on the context of where you right-click and what is
selected at the time. Choose the tools that are the most comfortable or natural for you to use
or that are best suited for a particular modeling task.
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ANSYS Electromagnetics Suite 2020 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.




Getting Started with HFSS: Waveguide T-Junction

« Create designs using your own discretionary workflow:

You do not need to follow a rigid sequence of events to create your design. This guide shows
a convenient method of creating the T-junction. However, you can execute the design steps
in any logical order.

« Quickly modify design properties:

For example, you can draw a box freehand and then specify its exact dimensions in the
docked Properties window. You can modify the properties at any time.

« Track modifications easily:

The History Tree and Project Manager help you keep track of your design modifications. The
branches of these trees provide organized lists of design steps completed (such as applied
boundaries, excitations, analysis setups, and created objects), and they provide access to
setup dialog boxes, where you can modify design properties.

« Take advantage of keyboard shortcuts:

Special hotkey combinations, like Ctrl+D (to fit the model in the view window), and many oth-
ers are available for frequently used commands. You can also create your own customized
keyboard shortcuts.

For more information, see the separate Getting Started guide, HFSS Keyboard Shortcuts.
« Parameterize design properties and save time:

For example, in this Getting Started guide, you can assign a design variable to the septum’s
position. This design variable enables you to quickly modify the design and generate new res-
ults, facilitating "what if' analysis variants.

« Optimetrics:

Automate the process of optimizing your designs. Specify a cost function and optimization
goals to achieve desired results in the most efficient way.

For more information, see the follow-up Getting Started guide, HFSS Tee Waveguide Optim-
ization.

« Evaluate results (post processing):

Many 2D and 3D plots, overlays, and animations of simulation results are available. For
example, in this sample model, the animations you create will help you visualize the dif-
ference in field pattern results for the two septum positions.

Sample Project — The Tee Junction

In this project you will design a T-junction with an inductive septum and analyze its behavior. This
structure splits an incoming microwave signal into two outgoing signals. The septum divides the
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signal, directs it to the output ports, and minimizes reflection at its input port.

A high frequency (10 GHz) signal enters the waveguide at Port 1 (see below) and exits at Ports 2
and 3. The position of the septum determines the relative transmission to Ports 2 and 3 and the
amount of signal reflection at Port 1.

Port 3

Figure 1-2: The Tee Junction Waveguide Model

Expected Results:

On the basis of prior simulations and product reviews (see footnote [1] at the bottom of this topic)
the following results were observed at a solution frequency of 10 GHz:

1. Ifthe septum is located centrally between output ports 2 and 3 (directly opposite from input
port 1), the signal divides equally between ports 2 and 3 (S12=S813=0.7).

2. With the septum located centrally, the incidental reflection at port 1 (S11) was slightly more
than 0.2.

3. Ifthe septum is moved 0.2 inches closer to port 2, transmission through port 2 (S12) is
reduced to slightly more than 0.4, and transmission through port 3 (S13) is increased to
about 0.9.

4. Atthe same septum offset of 0.2 inches, the incidental reflection at port 1 (S11) decreases to
slightly less than 0.1.

You will create a 2D x-y plot of the S-Parameters vs. Frequency for each septum position and
verify that your results agree with the expected results. You can also compare the E-field pattern at
each septum position by creating phase-animated field plots on the model geometry. These com-
parisons should indicate whether the field pattern changes with the septum’s position as expected.
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[1] “Parametrics and Optimization Using Ansoft HFSS,” Microwave Journal, Product Reviews,
November 1999.
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2 - Set Up the Tee Project

This chapter contains the following topics:
o Launch ANSYS Electronics Desktop
« Insertan HFSS Design
« Setthe Unit of Measurement
« Setthe Solution Type

Launch ANSYS Electronics Desktop:

For convenience, a shortcut to the ANSYS Electronics Desktop (EDT) application is placed on
your desktop during program installation. Optionally, you may want to pin the shortcut to your Win-
dows Start Menu too. Before proceeding to the next topic, launch EDT and add a blank project, as

follows:

1. Double-click the FI i ANSYS Electronics Desktop shortcut on your desktop (or the
same shortcut on your Start Menu).

The ANSYS Electronics Desktop application opens.

AMSYS Electronics Desktop - Project]
File Edit View Project Tools Window Help

j =] 2 | I |"_. ! % |5 Save Archive y Cut Undo g _reﬁ
J J
L] E Restore Archive y Copy Redo (S

Mew  Open Open Save Save  Close HF55 Q3D
Examples As L Paste X Delete o =
Dresktop View Simulation Automation
Project Manager o =

=-[3 Project1

Figure 2-1: ANSYS EDT Application Launched

2. Ifaprojectis not listed at the top of the Project Manager, click New on the Desktop ribbon
tab to include one. If the Project Manager window does not appear after launching the applic-
ation, go to the View menu and select the Project Manager option.
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Note:

Normally, a new, project is added automatically when you launch EDT. If you had
the application open already and closed the model you were working on, you will
have to add a new project manually.

3. Right-click Projectx at the top of the Project Manager and select Rename from the shortcut
menu.

4. Type Tee and press Enter.

The file Tee.aedt is saved to your default projects folder.

Insert an HFSS Design

1. Use one of the following methods to insert an HFSS design into the project:

« From the Desktop ribbon tab, click g HFSS.

Note:

There is no need to access the HFSS drop-down menu in this ribbon tab.
The default action is to insert a regular HFSS design.

» Fromthe menu bar, click Project> Insert HFSS Design:

AMSYS Electronics Desktop - Tee
File Edit WYiew Project Toels Window Help
~u & Insert HFSS Design
j —d @ Insert HFSS 3D Layout Design
il s el E};@ Insert Q30 Extractor Design
@& Insert 2D Extractor Design

Desktop Vie
+-|i Insert Circuit Design
Project Manager . .
+s'|5+ Insert Circuit Metlist
GRER] Tee

7l Insert EMIT Design
@ Insert Maxwell 30 Design

"HFSSDesignx" appears in the Project Manager.
2. Expandthe HFSSDesignx (DrivenModal) branch of the Project Manager.

Your screen should resemble the following figure:
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Eﬂ' AMNSYS Electronics Desktop - Tee - HFSS0esign1 - 30 Modeler - [Tee - HFS3Design1 - Modeler]
BT File Edit View Project Draw Modeler HFSS Tools Window Help
ﬂ | 4 Cut ¥ Undo | Select Objet - W @ +} Pan @, Fit an o O S s O N T
g (Redo | (G SelectbyMame % B A Furotate - EiFtseected F @ S| @ AT £ =
ave aom
BB raste X Delete ® « [ orient = e @ L9 &
Desktop View Drawe Model Simulation Results Automation
Project Manager oo FI-LL Coordinate Systems
Elm—'-l Tee* A EI & Planes z
= @} HF5SDesignl (DrivenModal,  § & € Lists #
: é 30 Components !
g vodel |
[3#] Crcuit Elements | 7/
- £ Boundaries |
2 Excitations | A
£ Hybrid Regions |
B8 Mesh | 7
- JF Analysis {
{78 optimetrics | -
[F] Resuts { /
{1 Port Field Display | B
W Fickd Overlays
Pk ‘ai’ Radiation
w1771 Miofinitinns "
< >
Properties 1 x ::i
H
Name |Value| Unt | Evahiated Va |

Figure 2-2: "HFSS Designx" Inserted into Tee Project

3. Onany ribbon tab, cIickH Save.

It's a good idea to save your model frequently as you add geometry, boundaries, excitations,
parameterizations, or analysis setups. By default, the program will autosave the model after
each set of ten (10) editing operations, and you can customize the autosave interval (Gen-
eral Options).

Set the Units of Measurement

Set the length unit to inches for drawing the Tee model, as follows:

Set Up the Tee Project 2-3
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1. On the Draw ribbon tab, click Units:

EER Measure - EH$ Grid

= Ruler ki -

Units I,:} 3D -

Figure 2-3: Location of Units Command on Draw Ribbon Tab
The Set Model Units dialog box appears.

2. Selectin (inches) from the Select units drop-down menu:

B set Model Units X

Select units: _ -

[ Rescale to new units

OF. | Carizel |

Figure 2-4: Set Model Units dialog

3. Click OK.

Set the Solution Type

The settings that HFSS offers in the user interface depends on the chosen solution type. For the
Tee Waveguide Junction, select the Modal solution type, as follows:

1. Using the menu bar, click HFSS> Solution Type.
The Solution Type dialog box appears.

Set Up the Tee Project 2-4
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2.

In the Solution Type dialog box, select Modal and then click OK.

Salution Types

Solution Type: Tee - HFS5Design

* Modal " Eigenmode
" Teminal (" Characteriztic Mode
" Tranzient " SER+

Driven Options

& Metwork &nalyzis

" Composite Excitation

X

[ Auto-Open Region

[ Save az default

k. | Caricel

Figure 2-5: Solution Type Dialog Box

This option ensures that HFSS will calculate the modal-based S-parameters using the
Driven Modal method. The S-matrix solutions will be expressed in terms of the incident and
reflected powers of the waveguide modes.

Note:

The convergence criterion for Modal solutions is the maximum Delta S (change in
modal S-matrix values) between consecutive iterations.

Description of Solution Types:

« Modal: Used for calculating the mode-based S-parameters of passive, high-frequency struc-
tures such as microstrips, waveguides, and transmission lines which are "driven" by a
source, and for computing incident plane wave scattering.

« Terminal: Used for calculating the terminal-based S-parameters of passive, high-frequency
structures with multi-conductor transmission line ports which are "driven" by a source. This
solution type results in a terminal-based description in terms of voltages and currents.
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Transient: Used for calculating problems in the time-domain (transient, short-duration
events). Use it for simulations with pulsed excitations (such as ultra-wide band antennas,
lightning strikes, and electrostatic discharge).

Eigenmode: Used to calculate resonant frequencies of structures (for example, filters) and
the fields at those frequencies. Frequency-dependent design parameters are not allowed.

Characteristic Mode: Used to calculate the characteristic modes (equiphase current
modes) of a conducting or dielectric structure, which are independent of any excitation. Only
discrete sweeps and lossless boundaries are supported. Results produced include char-
acteristic value, characteristic current, characteristic angle, and modal significance. The res-
ults are useful for problems involving syntheses, analyses, and optimization of antennas and
scatterers.

SBR+: Used to simplify design creation for SBR+ analyses (for use with Savant's Shooting
Bouncing Ray technology). A typical application is to determine the reflection signature of
radar targets. Ports and infinite ground planes are not allowed. At least one Incident Plane
Wave excitation must be defined. Yo do not have to define Hybrid Regions. Far field results
are calculated from current sources and the defined geometry.

Set Up the Tee Project 2-6
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3 - Create the Tee Model

This chapter contains the following topics:

Draw a Box

Alternative Method

Assign a Wave Port to the Box

Duplicate the Box

Duplicate Boundaries and Mesh Operations
Create the Second Section

Create the Third Section

Unite the Three Boxes

Create the Septum

Subtract Septum from T-junction

How To Draw the T-Junction:

The T-junction is made up of three box objects that are united through a Boolean operation and a
fourth box used to cut the septum. The geometry creation workflow is summarized as follows:

Draw a box to represent a section of the tee.

Assign a wave port to one of its faces.

Duplicate the box and wave port twice to create the second and third sections of the tee.
Unite the three sections to complete the Tee.

Draw a much smaller box and subtract it from the Tee to create the septum.

Note:

You will assign a design variable to control the septum position. This step will facil-
itate changing the position of the septum along the Y-axis, which will affect the rel-
ative signal transmission to the second and third ports of the tee.

The ensuing topics detail the above-summarized construction process.

Draw a Box

Before drawing any objects, check the 3D Modeler's Drawing options to ensure that the Properties
dialog box appears whenever you create a new object. Then, you can draw a box object to rep-
resent the first section of the Tee.

Set the Desired Drawing Options:
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o —
On the Desktop ribbon tab, click General Options.

2. Inthe tree on the left side of the Options dialog box, expand the 3D Modeler branch and
select the Drawing subheading.

3. Verify that the last option listed, Edit properties of new primitives, is selected and then

click OK.
Options
General M Drawing Data Entry Mode
2D Extractor
{* Poi { Di
Circuit Design Ho Dialog
Circuit MetList Design Ise F3/F4 to switch between point and dialog entry mode
HFS5
HFSS 30 Layout Relative Coordinate System Creation Mode
HFS5-IE
P i+ Axis/Position {" Euler angle
Maxwell 2D IUse F3/F4 to switch between axis position and Euler angle creation mode
Maxwell 30
Q3D Polyline Creation
RMxpri
Twin Builder v Automatically cover dosed polylines
= 30 Modeler
m [v¥ Show measure dialog during drawing
Operation 7 Ed f
Snap Edit properties of new primitives —-if——
Dizplay
Group
SpaceClaim Link
Advanced

Figure 3-1: Options Dialog Box — 3D Modeler> Drawing Options

Note:

When this option is selected, you can edit the properties of the objects in your
design within the Properties dialog box as soon as you create each one of them.
This method is an alternative to selecting items in the History Tree and editing the
properties in the docked Properties window.

Draw the First Box:

4. Onthe Draw ribbon tab, click @ Draw box.

5. Press F3 to specify the object size and location graphically or via the coordinate text boxes in
the status bar.
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Note:

You only need to press this key the first time you draw an object. The preference is
retained for future operations.

The Measure Data window appears and updates as you move the cursor.

£}

| | Reference coordinate system is Global

Position 1{Reference) = [0, 0, OJmm
Position2{Current) = [-0.1, -0.3, 0Jmm
Distance = 0.316227766mm

X Distance = 0. 1mm

Y Distance = 0.3mm

Z Distance = Omm

Close |

Figure 3-2: Measure Data Window

6. Click an arbitrary point on the grid in the Modeler window to establish the starting corner pos-
ition of the box.

Two mini Xy axes appear as shown below:

A=
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Figure 3-3: Mini XY Axes

7. Drag the mouse to form a rectangle and click again.

An arrow pointing upwards along the z-axis prompts you to set the height:

"-\—-_______-_

,

/

Figure 3-4: The Mini Z-axis to Set Height
8. Drag the mouse along the z-axis and click once more to create the box.

The Properties dialog box appears.

9. Inthe Command tab of the Properties dialog box, enter values of Position, XSize, YSize,
and ZSize as shown in the following figure:

Properties: Tee - HF55Design - Modeler
e |
Mame | Walue | Unit | Evaluated Value
Command CreateBox
Coordinate System | Global
Posttion 0.045.0 mim Ornm , -0.45mm . Omm
X5ize 2 mm 2mm
't Size 059 mim (. 9mm
Z5ize 04 mm (. 4mm

Figure 3-5: Properties Dialog Box — Command Tab

10. Select the Attribute tab, change the Name to Tee, and press Enter

11. Verify that the Material value is vacuum and the Material Appearance option is not selec-
ted.
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Note:

The default material is vacuum.

12. Click the button to the right of Transparent. Then, in the Set Transparency dialog box that
appears, set the value to 0.4, as shown below, and click OK.

EL] set Transparency =

[or

—_

Opaque Transparent

ak | Cancel |

Figure 3-6: Set Transparency dialog box

The Afttribute tab values should now match the following figure:

Command

Mame | Value | Lnit | Evaluated Value
MName Tee i
| Material "vacuum" - "vacuum"”
| Solve Inside [w
| |Orientation Global
| Model v
N Group Model
N Display Wireframe [
- |Material Appearance [ -—
N Color [ |
N Transparent 04 -1—'—

Figure 3-7: Properties Dialog Box — Attributes Tab
13. Click OK to close the Properties dialog box.

The first section of the Tee in the Modeler window should now resemble the following figure:
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Figure 3-8: The First Section of the Tee Structure
Alternative Method

In the previous topic, you drew a box of arbitrary location and size and then edited its properties to
produce the desired box. Another method of drawing the box and setting its coordinates and dimen-
sions is as follows:

1. Verify that the status bar at the bottom of the EDT application window has one of the fol-
lowing two messages displayed:

or

Ready Mathing is selected

Figure 3-9: Status Bar Messages when Ready to Draw an Object
2. Onthe Draw ribbon tab, click @ Draw box.

The status bar displays a new message:

Enter the box position.

Figure 3-10: Prompt to Specify Box Position

3. Press F3 to specify the object size and location graphically or via the coordinate text boxes in
the status bar.
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Note:

You only need to press this key the first time you draw an object. The preference is
retained for future operations.

4. Ensure that the indicated length unit at the far right end of the status bar is in (inches), as pre-

viously set.
5. Tabintothe X, Y, and Z coordinate entry text boxes near the right end of the status bar and
type in the following coordinates:

« X:0
e Y:-0.45
« Z:0

E e [oss ]z o [Jabsolut x| |cartesian ] i

Figure 3-11: Coordinate Text Boxes — Box Position
6. PressEnter.

The status bar message changes as follows:

Enter the opposite corner of the base rectangle.

Figure 3-12: Prompt for Opposite Corner of Base Rectangle

7. Tabintothe dX, dY, and dZ text boxes and type in the following coordinates, which specify
the XSize and YSize of the box:

« dX: 2
o dY: 0.9
« dZ: 0
dx |2 |-:I'.' ||;..g. |-:IE ||:| ||Re|atiueﬂ |'Cartesiar1 j in
Figure 3-13: Coordinate Text Boxes — Opposite Corner Relative Location
Tip:

If you enter a non-zero dZ value for the opposite corner (in this case, 0.4), you can
also simultaneously specify the height of the box, eliminating the necessity of com-
pleting steps 9 and 10.
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10.

11.

Press Enter.

The status bar message changes as follows:

Enter the height.

Figure 3-14: Prompt for Box Height

Tab into the dX, dY, and dZ text boxes and type in the following coordinates, which specify
the ZSize (height) of the box:

« dX: 0
« dY: 0
« dZ: 0.4

dx ||:. |-:I'|' ||:. |-:IE ||:|,4 ||F{e|atiuej |Cartesiar1 j i

Figure 3-15: Coordinate Text Boxes — Height of Box
Press Enter.
The Properties dialog box appears.

The values in the Command tab are already properly defined, since you specified the
coordinates numerically.

Return to step 9 of the prior Draw a Box topic and complete steps 9 through 12 to define the
box attributes. The process of editing the attributes is the same as for the first box-drawing
method described.

Assign a Wave Port to the Box

You will assign a wave port to the +X face of the box. You will also define an integration line, which
is a vector that specifies the direction of the excitation field pattern at the port. Integration lines
ensure that the field pattern is consistent at all ports.

Figure 3-16: Face of the box parallel to the yz plane at x=2
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1. Clickin the modeler window and press F to begin the face selection mode.
2. Click the face at the +X end of the box to select it:

Z

Figure 3-17: Wave Port Face Selected

3. Click the face of box parallel to the yz plane at x=2, as shown in Figure 3-16.

4. Right-click the Modeler window and choose Assign Excitation> Wave Port from the short-
cut menu.

The Wave Port : General dialog box appears.

5. Type Port1 in the Name text box.

6. Select New Line from the pull-down menu in the Integration Line column, as shown
below:

Wave Port : General

Mame: |'I
Mumber of Modes: |1
Mode Integration Line | Characteristic Inpedance (Zo)

|N0ne j

|N0ne

Figure 3-18: Selecting New Line Command for Integration Line
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The Measure Data dialog box appears, and the cursor is accompanied by a dotted line.

EH Measure Data

Reference coordinate system is Global

Position 1{Reference) = [2, 0, 0.2]in

Position2{Current) = [2, -0.8, 1.4in

Distance = 1.44222051in &
¥ Distance = Qin .

¥ Distance = 0.8in

Z Distance = -1.2in

Angle(P20 - P10) = 34.01820236deg

%

Figure 3-19: Measure Data Dialog Box and Integration Line Cursor

7. Select the starting point of the vector (2, 0, 0), by clicking the center of the selected face's bot-
tom edge. By default, the cursor should appear as a triangle and snap to this point:

Figure 3-20: Integration Line Starting Point
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8. Selectthe end point (2, 0, 0.4) by clicking the center of the selected face's bottom edge:

Figure 3-21: Integration Line Ending Point
The Wave Port : General dialog box reappears.

9. Click Next to accept the remaining default settings.
10. Click Finish.

11. Under Excitations in the Project Manager, select Port1 to display its visualization on the
model:

Figure 3-22: The Assigned Wave Port

Create the Tee Model 3-11
ANSYS Electromagnetics Suite 2020 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: Waveguide T-Junction

12. Clickin the Modeler window's background area to clear the current selection.

Duplicate the Box and Excitation

You must duplicate the box twice to create the second and third sections of the Tee. For con-
venience, you can also duplicate the boundary assignments, excitations, and any mesh operations
that have been defined along with duplicating the geometry. A program option controls whether
these extra items are copied with the geometry. Before duplicating the box, you will select the
needed option.

For the subject Tee, you will copy the box object and the wave port that was assigned to its face
(including the integration line and any other port settings). The names of the duplicated object and
wave port will be incremented automatically.

Enable Duplication of Boundaries and Mesh Operations with the Geometry

[ —
1. On the Desktop ribbon tab, click General Options.
2. Expandthe HFSS group and select the Boundary Assignment subitem.
3. Select the Duplicate boundaries/mesh operations with geometry option:

Options

General ~
2D Extractor [¥ Use Wizards for data input when creating new boundaries
Circuit Design
Circuit MetlList Design
= HF55
General
Materials v Auto-assign terminals on ports
Boundary Assignment
Post Processing
HFS5 30 Layout

[+ Duplicate boundaries/mesh operations with geoMeiry f—

[+ Visualize boundaries on geometry

Figure 3-23: HFSS> Boundary Assignment Options
4. Click OK.

Create the Second Section
You will duplicate the first box to create the second section.

5. Under Model> Solids> vacuum in the History Tree, click Tee to select the object.
6. Onthe Draw ribbon tab, click [ Around Axis (Duplicate Around Axis).

The Measure Data and Duplicate Around Axis dialog boxes appear.
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7. Ensure that the settings in the Duplicate Around Axis dialog box match the following spe-
cifications and figure:

o« Axis:Z
« Angle: 90 deg
Note:

A positive angle causes the copied object to be rotated in the counter-clock-
wise direction about the specified axis.

« Total number: 2

Note:

This value is the total number of objects after duplication, including the ori-
ginal one.

« Attach To Original Object: Not selected

E] buplicate Around Axis >

Az W Yy ez

Angle: |E||:| - -
Tatal number: |2 ﬂ

Attach To Original Object: [

MOTE: “When ‘Attach to Onginal Object’ iz selected,
face/edge aszignments [e.0. boundaries/excitations]
on duplicates will be lost, to ensure model
congigtency, when 'Total Mumber' iz edited.

Cancel

Figure 3-24: Settings for the First Duplication

8. Press Ctrl+D to fit the view, if needed.

The preview of the duplicate box in the Modeler window should look like the following figure:
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Figure 3-25: Preview of the First Box Duplication

9. Click OK.

The box is duplicated, the duplicated wave port and its integration line are displayed, and the
Properties dialog box appears.

10. Click OK to dismiss the Properties dialog box.
11. Clear the current selection.

Note:

The first box (Tee) was duplicated at the specified location, and the rotated copy named
Tee_1. The attributes of the parent object (including its dimensions, material, color, and
transparency) were duplicated. Port1 was also duplicated along with its integration line.
The duplicate was named Port2 and listed under Excitations in the Project Manager.

Create the Third Section

1. Using the same procedure as detailed in the previous topic, duplicate the first box (Tee)
again, but this time, specify -90 deg for the Angle.
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Note:

A negative angle causes the copied object to be rotated in the clockwise direction
about the specified axis.

2. Press Ctrl+D to fit the objects within the view window.
3. Clear the current selection.

Your model should now look like the following figure:

Z

Figure 3-26: The Tee Model after Duplications are Completed

In the next procedure, you will unite the three separate boxes into a single object.

Unite the Three Boxes

To create the complete T-junction, you must unite the three separate boxes into a single object.
Before doing so, there's a program option that you must verify is disabled.

e
1. Onthe Desktop ribbon tab, click General Options
The Options dialog box appears.

2. Expandthe 3D Modeler group and select the Operation subitem.

3. Verify that the options, Clone tool objects before uniting and Clone tool objects
before subtracting, are not selected.
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Options
HFS5 30 Layout M Clane
HFS5-IE [ Clone tool objects before uniting  f—
Icepak
Mazawell 20 [ Clone tool objects before subtracting  f—
Mazxwell 3D [ Clone tool objects before intersecting
Q3D
RMuprt [ Clone tool objects before imprinting
Twin Builder | Clone tool objects before projecting
= 30 Modeler
Drawing Comrdinate Svsta
- oordinate System
Snap [ Automatically switch to face coordinate system
Dizplay
Group Model Edit
SpaceClaim Link
Advanced [+ Delete invalid objects created during split operation
Layout Editor | Automatically imprint wrapped sheets
Machines
Figure 3-27: 3D Modeler> Operation Options
Note:

You don't want the ANSYS Electronics Desktop application to create copies of the
original objects before uniting them. The original parts, as separate boxes, will not
be a part of the analysis model. Therefore, you must deselect the Clone tool objects
before uniting option if it is currently selected. In a later procedure, you will also per-
form a subtraction. For that operation, you likewise do not want the tool object
cloned. Since you're already visiting the 3D Modeler> Operation settings, you can
check the state of both options now.

Click OK.
Press O to begin the object selection mode.
Click the first box to select it (the one running in the direction of the X-axis).

The selection order of the objects is important because it determines the name of the united
object.

Hold the Ctrl key and click the second and third boxes.
On the Draw ribbon tab, click 2 Unite.

The objects are united into a single contiguous volume. The new object has the same name
(Tee) and attributes as the first object selected.
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Figure 3-28: The United Tee Object

Create the Septum

You will create a small box to use as a cutting tool. You will also define a design variable to control
the Y-position of this box so that the septum'’s location can be fine-tuned easily. (In the subsequent
topic, you will subtract the small box from the T-Junction to complete the septum.)

1. Onthe Draw ribbon tab, click @ Draw box.
2. Click at three different points in the Modeler window to draw an arbitrary box.

As soon as you click the third point, the Properties dialog box appears.

3. Under the Command tab of the Propertieswindow, specify the following set of coordinates
for the Position Value:

o -0.45in, Offset-0.05in, Oin
4. Press Enter.

The Add Variable dialog box appears.
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5. Inthe Value text box, specify 0in and click OK to define the initial Offset value.

Note:

You must define the unit of measurement, but you can do that as part of the Value
entry (without using the Unit Type and Unit drop-down menus):

Add Variable >

M ame |I:Iffset

Irit Type |N|:une j

Urit | |

Value  [fin  —

Tupe | Local Yariable J

OF. | Cancel |

Figure 3-29: Add Variable Dialog Box

6. Specify the following additional values in the Command tab of the Properties dialog box:
« XSize=0.45
o YSize=0.1
o ZSize=0.4

The settings under the Command tab should agree with the following figure:

[Com] e |

MName | Value | it | Evaluated Value |
Command CreateBox
| |Coordinate System | Global
| | Posttion 40.45in Offset-0.05in ,0in -0.45in , 40.05in , 0in
[ %Size 0.45 in 0.45in
- |vsize 0.1 in |01
| [ZSiee 04 in 0.4in

Figure 3-30: Cutting Box Properties — Command Tab
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7. Under the Attribute tab of the Properties dialog box, change the Name to Septum.
8. Click OK.

With the cutting box (Septum) still selected, your model should look like the following figure:

Z

Figure 3-31: Septum Cutting Box Created

9. Clear the selection.

Subtract Septum from the T-Junction
To complete the model geometry, you must subtract the septum object from the T-junction.

1. Under Model> Solids> vacuum in the History Tree, click Tee to select it.
2. Hold down the Ctrl key and also click Septum in the History Tree.

Note:

The order of object selection determines which part is the Blank Part and which is
the Tool Part when you perform a subtraction.

3. Onthe Draw ribbon tab, click Es' Subtract.

The Subtract dialog box appears. Ensure that each object is listed in the correct parts list, as
shown below:
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E subtract >

Blark Parts - Tool Parts

Tee Septum
]
=

| |

[” Clone tool objects before operation

| k. I Cancel

Figure 3-32: Subtract Dialog Box

Note:
The Tool Part (Septum) will be subtracted from the Blank Part (Tee).

4. Verify that the Clone tool objects before subtracting option is not selected.
5. Click OK.

The Septum is subtracted from the Tee. The resulting object has the same attributes as the
first object you selected.

E--' Madel
547 Solids
= 4% vacuum
B4 Tee
ﬁ CreateBox
i.| DuplicateAr
-] DuplicateAr
...'1—_|-, Unite
IE Subtract
#-l, Coordinate Systems
[+ Planes
- Lists

Figure 3-33: The Completed Model Geometry
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4 - Solve the Design

This chapter covers the following topics:
» Add Solution Setup to the Design
« Validate and Analyze the Tee
« Modify the Septum’s Position and Reanalyze

Add Solution Setup to the Design

In this procedure, you will specify how HFSS should compute the solution by adding a solution
setup to the design. Set up the solution such that HFSS performs an adaptive analysis at a fre-
quency of 10 GHz.

Note:

During an adaptive analysis, HFSS refines the mesh iteratively in the areas of highest
error.

1. From the Simulation ribbon tab, click & Setup> Advanced.
The Driven Solution Setup dialog box appears.

2. Onthe General tab of the dialog box, type 10 in the Frequency text box. (Leave the default
frequency unit setto GHz.)

Note:

The Maximum Number of Passes, which is 6 by default, is the maximum number of
iterative passes that HFSS will perform. From the second pass on, if the con-
vergence criterion (Max Delta S in this case) is not satisfied, the mesh is refined
and another iteration performed. The solution stops after the specified maximum
number of passes has been completed, whether the solution has converged or not.
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Driven Solution Setup >

General letiu:uns ] Advanced ] Hybrid ] Expression Cache | Dervatives ] Defaults ]

Setup Mame |Setu|:u1

v Enabled [ Solve Ports Only

Adaptive Solutions

Solution Frequency: {* Single " Multi-Frequendes (" Broadband
Frequency | 10 GHz ﬂ
Maximum Mumber of Passes | 6

(% Maximum Delta S | 0.02

" Use Matrix Convergence

Figure 4-1: Figure 4-1 Driven Solution Setup
3. Accept the remaining default settings and click OK.

The solution setup, named Setup 1 by default, is listed under Analysis in the Project Man-
ager.

Add a Frequency Sweep to the Setup

You can add a sweep to the solution set-up for HFSS to solve over a range of frequencies. A
smooth frequency response is expected for this design, so you will select an interpolating fre-
guency sweep.

Note:

An Interpolating sweep estimates a solution for an entire frequency range. HFSS
chooses the frequency points at which to solve the field solution so that the entire inter-
polated solution lies within a specified error tolerance.

The sweep is complete when the solution meets the error tolerance criterion or generates the max-
imum number of solutions. The sweep is solved after the adaptive analysis is complete.

1. Right-click Setup1 under Analysis in the Project Manager, and choose Add Frequency
Sweep from the shortcut menu.
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—
Alternatively, on the Simulation ribbon tab, click LJ‘ Sweep (Add Frequency Sweep).

But, to make this command available, you must first select the analysis setup, in the Project

Manager, to which the sweep will apply (Setup1 in this case).
The Edit Frequency Sweep dialog box appears.

2. Specify the following settings under the General tab of the dialog box:
a. Sweep Name: Sweep1
Sweep Type : Interpolating
Distribution: Choose Linear Step from the drop-down menu.
Start: 8Ghz
End: 10 GHz
Step Size (this column depends on the Distribution menu selection): 0.05GHz

-~ ® 2 o T

Edit Frequency Sweep x

General l Interpolation ] Defaults ]

Sweep Mame: |Sweep1 [+ Enabled
Sweep Type: |Ir|ter|:u:||ating ﬂ
Freguency Sweeps [41 points defined]
Distribution Start End
Bl Linear Step 8GHz 10GHz Step size 0.05GHz
Add Above | Add Below | | Preview ... |

Figure 4-2: Frequency Sweep Settings

Note:

HFSS will solve the frequency point at each step in the specified range, including
the start and stop frequencies.

3. Click OK.

Sweep1is listed under Analysis> Setup1 in the Project Manager.
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Note:

Before performing the solution setup you must assign wave ports to the model.
Otherwise, the Edit Frequency Sweep dialog box will not contain an Interpolating
choice in the Sweep Type drop-down menu.

Validate and Analyze the Tee

Because you parameterized the septum position, you can easily move the septum to various pos-
itions, run the simulations to generate the corresponding results, and review the resulting behavior
of the Tee-structure. Before you run an analysis, verify that all of the necessary setup steps have
been completed and their parameters are reasonable.

Validate the Design:

1. Onthe Simulation ribbon tab, click \/ Validate.

The Validation Check window appears, and HFSS checks the project setup. There should
be no errors or warnings:

Validation Checlk: Tee - HF55Design1 >
) ¥ Design Settings
& HFsSDesign & 3D Model
" Boundaries and Excitations
Yalidation Check cormpleted. & Mesh Operations
& Analysiz Setup
" Dptimetrics
¥ Radiation
| Cloze |

Figure 4-3: Validation Check
2. ClickClose.

You are ready to run the simulation.

Analyze the Tee:

Next, analyze the design with the septum placed centrally, opposite from Port1:
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3. From the Simulation ribbon tab, click (o} Analyze All.

HFSS computes the solution for every analysis setup in the project. In this exercise, Setup1
is the only setup you defined. In situations where you have a design with multiple setups and
prefer to run only one, you can right-click on a single setup in the Project Manager and select
Analyze from the shortcut menu.

Note:

The solution process takes approximately 30 seconds to a few minutes to com-
plete, depending on your computer hardware. When the solution is complete, a con-
firmation message appears in the Message Manager window.

Modify the Septum’s Position and Reanalyze

Change the Septum Offset:
You can modify the septum’s position by varying the offset, as follows:

1. Fromthe menu bar, click HFSS> Design Properties or right-click HFSSDesign1 (Driv-
enModal) in the Project Manager and choose Design Properties from the shortcut menu.

The Properties dialog box appears.

Properties: Tee - HF55Design

Local Varables l

* Value " Optimization / Design of Experiments " Tuning {" Sensitivity
Mame | Walue | Uit | Evaluated Value | Type | Description | Read-only |
Offaet 0.2 in 0.2in Diesign [

Figure 4-4: Design Properties — Local Variables

2. Ensure that the Value option is selected.
3. Forthe variable Offset, type 0.2 in the Value column.
4. Click OK.

The Tee is updated with the new 0.2 inch Offset value:
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Z

Figure 4-5: Tee with Septum Offset = 0.2 Inch

Reanalyze the Tee:

You will run a fresh simulation to generate results for the T-junction variant with the septum located
off-center, closer to Port2.

Note:

The previous solution is saved and the original results remain available for post pro-
cessing.

5. Right-click Setup1 under Analysis in the Project Manager and select Analyze.

HFSS computes the setup and sweep solution for the offset Septum variant of the T-junc-
tion.
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Families tab for XY Plot

5 - Compare the Solutions

This chapter covers the following topics:
o S-Parameter vs. Frequency Plot
« Add Data Markers
« Visualize E-Field at Zero Offset
o Modify Septum Position
o Create E-Field Overlay
o Animate the E-Field
« Visualize E-Field at 0.2 Inch Offset
o What's Next?

S-Parameter vs. Frequency Plot

You will create a 2D x-y (rectangular) plot to compare the S-parameter results at each port for the
two septum positions.

i I
:’fl Al ," I'
1. Onthe Results ribbon tab, click =1 Modal Solution Data Report> "V “_|2D.

The Report dialog box appears.

2. Inthe Context section and under the Trace tab, specify the following settings:
a. Solution = Setup1:Sweep1
Domain = Sweep
Primary Sweep = Freq
Category = S Parameter
Quantity = S(Port1,Port1), S(Port1,Port2), S(Port1,Port3) (for the Y axis)
Function = mag

@ -~ ® & o T

X axis value = Default (Freq)
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K2l Report: Tee - HFSSDesign1 - New Report - New Trace(s)
S Families ] Families Display ]
Solution: .
Setupl : Sweepl
| Ewp Weep ﬂ Primary Sweep: |FFEI:| ﬂ |P||| J
Domain: S
| Heep ﬂ X v Default |F|'Eq J
4 ¥ |mag[5[Pu:urt1 Port1)); mag(S(Port1,Port2)); mag(S(Portl,Port3)) ——
- r ’ r ! ' Function...
Category: Quantity: =~ Function:
Variables S(Port1,Portl) <none:
Qutput Variables 5(Port2,Port1) ang_ﬂeg I
Eh_ ang_deq_va
Y Parameter 5(Port3,Portl) ang_rad
Z Parameter 5(Port1,Port2) arg
VEWR S(Port2,Port2) cang_deg
Gamma 5{Port3,Port?) cang_deg_val
E;rr:hﬂ; 5(PortL,Port3) ;;”g—rad
Epsilon 5(Port2,Port3) dB 10normalize
Group Delay S{Port3,Port3) dB20normalize
Active S Parameter dBc
Active ¥ Parameter im
Active Z Parameter mag |
Active VSWR normalize
Update Report Passivity re
Design
v Real time

Figure 5-1: S Parameter vs. Frequency Report Settings — Trace Tab

3. Under the Families tab, ensure that the Value column for the Offset variable is set to All. If
not, click the ellipsis button [...] and select the Use all values option.

Trace Families Display ]

Families : 2 available

f* Sweeps ( Available variations

| Variable | Value | Edit |

Jﬂﬁset Al —

Figure 5-2: S Parameter vs. Frequency Report Settings — Families Tab
4. Click New Report and then click Close.

The magnitude of the specified S-parameters at each Offset value are plotted against fre-
quency on an x-y graph:
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S Parameter Plot 1 HFSSDesign1

1.00

Curve Info

- = mag(3({Port1,Port1))
- Setup1 : Sweep

0.80 — Offset="0in"
mag(3(Port1,Port1))

Setup1 : Sweep1
4 Offset="0.2in"

0.60 — = mag(Z(Port1,Port2))
Setup1 : Sweep1
Offset="0in"

%1

i mag(S(Port1,Port2}){
0.40 — Setup1 : Sweep1
7 Offset="0.2in"

mag(3(Port1,Port3))
Setup1 : Sweep
0.20 - Offset="0in"

= mag(3{Port1,Pori3))
Setup1 : Sweep1
Offset="0.2in"

U,UU|||||||||||||||||||||||||||||||||||||||
§.00 8.25 8.50 875 9.00 925 950 975 10.00

Freq [GHz]

Figure 5-3: S-Parameter vs. Frequency Plot

This plot is listed under Results in the Project Manager along with its three corresponding
trace definitions. The plot legend shows the Curve Info for each trace. Since you specified
three S-parameters, and two Offset values were solved, there are six traces.
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Observations:
« Two of the traces are directly on top of each other (cyan and medium blue).

These two curves represent the relative signal transmission from Port1 to
Port2 and from Port 1 to Port3 with zero Offset of the Septum. The signal
divides evenly and is fairly constant at approximately 0.7 across the swept
frequency range, only decreasing slightly with increased frequency. The
magnitude of this result at the adaptive solution frequency of 10 GHz is
approximately 0.68.

o At0.2inch Septum offset, the transmission to Port3 (dark green curve) is
greater than the transmission to Port2 (orange curve) across the full sweep.
The magnitude of the signal transmitted to Port3 decreases as the frequency
increases, whereas the magnitude at Port2 increases as the Frequency
increases. At the adaptive solution frequency of 10 GHz, S(Port1,Port3) is
about 0.9 (an increase of 0.2 relative to the zero Offset result). For the same
conditions, S(Port1,Port2) is 0.44 (a decrease of about 0.24 relative to the
zero Offset result).

« Atzero Offset, the reflection at Port1 (red curve) increases across the full
swept range as the Frequency increases. The S(Port1,Port1) parameter at
the adaptive solution frequency of 10 GHz is approximately 0.2.

« With an Offset of 0.2 inch there is less reflection at Port1 throughout the
swept range (light green curve), and it is minimal at just under 9 GHz. At the
adaptive solution frequency of 10 GHz, S(Port1,Port1) is about 0.08.

The current results are consistent with those observed from prior simulations and
product reviews. (See the earlier-presented Expected Results discussion.)

Add Data Markers

You can add data point markers along any of the traces, if desired. Additionally, you can control
how frequently the marker symbols are added. For example, a Symbol Frequency of 1 places a
marker at every calculated data point; whereas a Symbol Frequency of 5 places a marker on every
fifth calculated data point.

1. Click a trace on the plot to which you intend to add data markers (for example, the orange
trace).

The trace properties appear in the docked Properties window:
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Properties o =

Name Value |

Mame mag(5(Port 1, Port 2)):Offset="0.3n" [Cu...

Coalar I |

Line Style Solid

Line Width 3

Trace Type Cortinuous

Show Symbaol [

Symbal Frequency 5

Symbal Style Vertical Hlipse

Fill Symbal

Symbol Color ]

Show Amows [

Btributes | Cartesian | General |

Figure 5-4: Trace Properties — mag(S(Port1,Port2)):Offset="0.2in"

2. Selectthe Show Symbol option.

3. Enter 5 asthe Symbol Frequency value and press Enter.

4. Clickin the plot background area to clear the selection.

Data point markers appear on the trace, as shown below:

Y1

0.40

____O-——l—"

—

e

Figure 5-5: Data Markers Added to a Trace

Visualize E-Field at Zero Offset

Create and animate an E-Field overlay to look at the signal propagation with the Septum posi-
tioned directly opposite Port1 (exactly centered between Port2 and Port3). A field overlay plot rep-
resents a field quantity on a surface or within an object. You will plot the magnitude of the E-field on

the top surface of the Tee.

Offset="0in"

—5~  mag(S(Port1 Port2))|_

Setup1 : Sweep1
Offset="0.2in"

mag(3({Port1,Port3))
Sehint - Sweend

Before creating the overlay, you must first modify the Offset design variable again, to return the
Septum to its original location.
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Modify the Septum Position

1. Use the Window menu to return to the Modeler window, which may presently be covered
by the S-parameter plot.

Alternatively, if the Modeler window is partially visible, simply click it to bring the window to
the foreground.

2. Fromthe menu bar, click HFSS> Design Properties.
The Local Variables tab of the Properties dialog box appears.

3. Ensure that the Value option is selected.
4. Forthe Offset variable, type 0 in the Value column.
5. Click OK.

The Tee geometry is updated with the original (centered) position of the septum restored.
Create the E-Field Overlay

1. PressF or right-click in the Modeler window and choose Select Faces from the shortcut
menu.

2. Selectthe top face of the Tee:

Figure 5-6: Top Face of Tee Selected

3. Inthe Project Manager, right-click Field Overlays and select Plot Fields> E> Mag_E.
The Create Field Plot dialog box appears.
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4. Verify that the settings are as shown in the following figure:

Modify Field Plot >
[ Specify Mame |Mag_E'I Fields Calculatar ... |
™ Speciy Folder [E Field | Categony |Standad v
Deszign: HFSSDesignl [uantity [ Y alume
Context
CENN . Tee
S olution: |Setup1 : Lastidaptive j Complextdag_E All0bjects
Wector_E
kag_H
Field Tppe: |Fielu:|s J Complestdag_H
Wector_H
Intrinzic Wariables Edsrﬁﬁf:rr:;agj surf
Wector_Jsurf
=g |1DGH2 j tag_Jval
Complextdag_Jwal
Phase j Wector_Jval
kag_JIm
Complextdag_Jm
Wector_JIm
Save Az Default | ABS_( [
Smoathl) v

| Daone | Cancel

Figure 5-7: Create Field Plot Dialog Box

5. Click Done to accept the default settings.

The overlay appears on the top face of the T-junction and it is listed as Mag_E 1 (the default
name) under Field Overlays in the Project Manager.

The overlay shows the E-field distributed evenly toward Port 2 and Port 3.
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E Field

[Vim]
3275.7634
3057.3792

2838.9951
2620.6108
2402 2266
2183.8423
19654581
1747.0735

.1525.6896

1310.3064

1091.9211
873.5369
6851527
436.7685
218.3842

00000

Figure 5-8: Mag_E1 Overlay with Septum at Zero Offset

6. Optionally, you can modify the plot display by double-clicking within the legend box to access
a variety of settings (such as color map and scale options). Click Close when done.
Animate the E-Field

An animated plot is a series of frames that displays a field, mesh, or geometry at varying values (in
this case, varying phase angle). You must specify the values of the plot that you want to include.
Each value is a frame in the animation.

1. Right-click Mag_E1 under Field Overlays> E Field in the Project Manager and choose Anim-
ate.

The Set-up Animation dialog box appears.
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2. Verify the default settings, as shown in the following figure, and click OK.

Create Animation Setup >

Mame: |Animation] Description: |

Swept Variable(s) l Design Point |

|Single varizble ¥ | [

Start: |[‘.\:|eg

Stop: |1 7ldeg

Steps: |-I 7

Figure 5-9: Setup Animation Dialog Box

The Animation dialog box appears, enabling you to stop, restart, reverse, and control the
speed of the frames.

Animation: Animationl = 2
. :
| 4| = | »|
Speed
Frame: 8. Phaze = 140deq =,
Cloze
Label:
B ackground: Fant ¥ Show

Figure 5-10: Animation Dialog Box

The animation begins and shows the Septum dividing the electromagnetic wave evenly
toward Port 2 and Port 3. The field is displayed at 18 phase values between 0 and
170 degrees, inclusively (17 increments of 10° each).
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E Field <
[Vim]

3419.6353
3191.86504

2963.6838
27357000
25077324
2279 7568
2051.7810
1823.8054

. 15955297

13678540

1139.8784

911.9027
683.9270 i

R Phase = Odeg I
227 9757

LIRELLE

Figure 5-11: E-Field Animation — Zero Septum Offset

3. Inthe Animation dialog box, click Close.

Visualize E-Field at 0.2 Inch Offset

Create and animate an E-Field overlay to look at the signal propagation with the Septum Offset 0.2
inches toward Port2.

Before creating the overlay, you must first modify the Offset design variable again to place it at the
desired position for the animation.

Modify the Septum Position:
1. Fromthe menu bar, click HFSS> Design Properties.
The Local Variables tab of the Properties dialog box appears.

2. Ensure that the Value option is selected.
3. For the Offset variable, type 0.2 in the Value column.
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4.

Click OK.

The Tee geometry is updated to place the Septum 0.2 inches offset toward Port2. Also, the
E-field overlay is immediately updated. Now, more energy is flowing toward Port3 than

Port2.

Animate the Revised E-Field Overlay:

5.

Right-click Mag_E1 under Field Overlays> E Field in the Project Manager and choose Anim-

ate.

The Select Animation dialog box appears and previously defined Animation1 is selected.

Click OK to access the Animation dialog box and start the animation:

Z

E Field
[Vim]

31451074
I 25935 4336
2725 7593
2516.0855
2306.4121
2006. 7303
1887.0645
16773906

- 1467.7163
1258.0430
1048.3691
838.6053
629.0215
4183477

209.6738
0. 0000

Phase = Odeg I

Figure 5-12: E-Field Animation — 0.2 Inch Septum Offset

7. H Save your project.
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What's Next?

You have successfully completed creating the T-Junction Waveguide and evaluating the behavior
of its electromagnetic field. If desired, you can proceed immediately to the follow-up guide, Getting
Started with HFSS: Optimizing a Waveguide T Junction, where you will learn about Optimetrics
using this model.

Choose one of the following three actions:

« Leave this project open and proceed to the follow-up guide, Getting Started with HFSS:
Optimizing a Waveguide T Junction. This guide is located in the HFSS Tee Waveguide
Optimization branch of the HFSS help. Itis also available as a PDF file from the HFSS PDFs
topic.

« To close this project but leave the application running, use the menu bar and click File>
Close.

« Toclose this project and exit the application, click File> Exit.
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